InDesign prints show non existing Photoshop layers!

Learn / Forums / General InDesign Topics / InDesign prints show non existing Photoshop layers!

Viewing 3 reply threads
  • Author
    Posts
    • #14328453
      Design Dept
      Member

      Ok, this one has stumped me.
      I have a psd placed into ID. When I print it, the image shows psd layers that don’t exist in the psd file. They show as lightish blue layers, almost like their layer mode is overlay. Almost like ghost layers.
      Even if I flatten the psd into a jpg, re-place into ID, the weird layer things still show!
      When I print from PSD, they do NOT show, it looks perfect in PS and ID on screen, the problem only occurs when printing from ID.
      Photoshop also prints perfectly, no ghost layers.
      I’ve tried different printing presets/colour handling options in ID – doesn’t sort it.
      It seems like ID can see some older PSD layers that DO NOT exist in the PSD, and then shows them when printing.
      There’s no paths or extra channels in the PSD, just a normal cmyk, psd file with layers (but NOT the ghost layers).
      I wish I could attach images to show you the issue, this is driving me mad.
      Any suggestions?

    • #14331354
      Design Dept
      Member

      One more thing to add.
      If I export the file to PDF, then print that – it’s perfect.
      The issue is with printing from InDesign.

    • #14331355
      David Blatner
      Keymaster

      Wow. Maybe call an exorcist? (Just kidding.)
      This does sound very, very strange. If you place it in a new clean InDesign doc and print from there, does it still happen?

    • #126406
      Design Dept
      Member

      OK I’ve discovered that it’s white gaps in my PSD channels. For some reason there are white boxes from the original layers.
      But, when I print from Photoshop, the image prints perfect. When I print from ID, it shows these white boxes as ‘ghost’ layers.
      So ID is reading the file differently to PS.. I guess…dunno..

Viewing 3 reply threads
  • You must be logged in to reply to this topic.
>