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YOUR SECOND PAGE: MOVING BEYOND BLAND

Although the page you’ve created in the previous section won’t be
Site of the Week anytime soon, it does have a few key Web objects—
text, graphics, and links. At this point, we want to do something
about the bland text and boring layout.

When your browser displayed the page you created in the previous
section, it used whatever its default font happened to be. That’s
because you didn’t specify which font the browser should use or
whether the text should be “styled” in a certain color, size, or weight.

However, styling text means more than making it pretty. How text
looks signals your readers about how you’ve structured your content.
For example, readers should be able to tell at a glance what your main
heading is, as well as immediately recognize your various subheadings
and the main body of your page. And you definitely want them to
instantly recognize a link or a warning when they see one.

This doesn’t imply that attractiveness shouldn’t matter but rather
that how text looks carries meaning. The best tool to style text for
both appearance and function is Cascading Style Sheets (CSS), a
set of rules that all modern browsers support.

Understand Styles
A style is a description that tells the browser how to display text. To
pick up on the examples in the intro to this section, you might decide
that the style for your main head should be this:

MAIN HEAD
That is, its font would be Arial, its weight bold, its color red, and its
size large. (See the “Defining Font Sizes” note (next page) for what I
mean by “large.”)

You might also decide that your first subhead should have this style:

Subhead

Like your main head, its font would also be Arial, its weight bold,
and its color red. Its size, however, would be medium. And finally,
you might want your body text to look like this:

Body text
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Once again, its font would be Arial, but its weight would be normal,
its color black, and its size small.

So a particular combination of attributes, such as font, size, weight,
and color, constitutes a style. Think of a style as a kind of shorthand:
rather than specifying a separate attribute for every chunk of text, you
specify a single style, and the browser takes care of the details. That
saves time when you design, reduces the places where you can make
a mistake, and—not incidentally—produces a smaller file size for your
page (always a good thing).

Here’s where Dreamweaver helps out: I’ve described styles above
informally. But in order for a browser to understand how text should
look, you have to describe it precisely, using only permitted CSS
syntax. While that’s not inherently difficult, it’s one more thing to
learn. As we’ll see shortly, Dreamweaver generates the correct CSS
code for you.

NOTE DEFINING FONT SIZES

Many designers use pixels—short for “picture elements”—to set
font size. It’s convenient and works in most cases. However, some
browsers—notably, Internet Explorer for Windows version 6—won’t
let users resize text defined in pixels. In addition, font sizes defined
in pixels can be too small on Macintosh monitors; see
http://db.tidbits.com/getbits.acgi?tbart=05284 for the details,
especially the “Pixel Dust” section.

To overcome this problem, you can use a “relative measurement,”
that is, one relative to the browser’s default size. For example,
Dreamweaver lets you define font sizes ranging from xx-large to
xx-small. (It also permits ems and percentages, two other relative
measurements.) Browsers then permit resizing; although results
may vary among browsers, each browser renders text consistently.

However, given the permutations and combinations possible
with browsers and font measurements, check your pages on all
the browsers your audience is likely to use to make sure text looks
as you intend.

http://db.tidbits.com/getbits.acgi?tbart=05284
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But wait, there’s more. The real power of a style kicks in after you’ve
applied it and then want to make changes. It doesn’t matter if you’ve
used a particular style once or a thousand times on your site: change
it—for example, make the font size larger—and that change immedi-
ately takes effect everywhere. Every time the browser sees a reference
to the style, it uses the most up-to-date version.

Warning! Alas, that last sentence is only theoretically true; some
browsers are dumb and require you to reload a page before they use
the updated version of your style sheet. However, that should affect
only you when you’re testing your work, not your visitors when they
come to your site.

NOTE THE BAD OLD DAYS OF STYLING TEXT

Things were not always so slick. In the prehistoric days of the Web
design—say, 5 years ago—what support there was for CSS was pretty
spotty. Rather than using CSS, designers had to style text one attri-
bute at a time using the <font> tag. That was so time-consuming and
so error-prone that the World Wide Web Consortium—the group that
sets standards on the Web—deprecated the <font> tag, which means
that future browsers may no longer support it. That may not happen
for 5 or 10 years, but it will happen. So not only do styles make your
life easier, but also they’re the only way you can be sure that your
pages will continue to display as you intended.

Understand Style Sheets
A style sheet is a collection of styles. Think of it as a container in
which you store style definitions, themselves containers in which
you store the specifics of each style. Style sheets are ordinary text files
that use .css as a file extension. Just as browsers know how to display
files that end with .html or .htm, browsers know how to use .css files
to style text. You can create style sheets and styles with any plain text
editor, but, of course, that’s not why you bought Dreamweaver.
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Construct Styles and Style Sheets
Before you start to build your own styles and style sheets, here’s an
overview of the four-part process of styling text in Dreamweaver:

1. Create a few styles in a style sheet. (If you already have a style
sheet, you can link it to a page you’re working on.)

2. Select some text and apply a style to it.

3. See how your text looks, either in Dreamweaver or a browser.

4. Edit the style as appropriate; the text automatically updates.

Work along with me, tutorial style, as we go through the entire
sequence in more detail:

Create a new HTML document containing text:

1. In Dreamweaver, choose File > New.

2. In the New Document dialog, click General, and then select Basic
page from the Category list and HTML from the Basic page list.

3. Click Create.

Dreamweaver opens a new untitled document.

4. Choose File > Save, navigate to the folder you’ve been using, and
save the file as mysecondpage.html.

5. Enter (or paste in) the following three lines of text, each separated
by a carriage return:

Main Heading
Subhead
Here is some body text.

Create a style sheet and a siteHeader style:

1. Choose Window > CSS Styles. The CSS panel opens (by default,
it opens at the far right), with a message that no styles are defined
(Figure 7). Click All, if necessary, to see the message.
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FIGURE 7

Click the All button near the top of the CSS panel to list all the styles
you have defined for a page (as shown here). Or, click the Current
button to list only the styles used by the currently selected text.

2. Click the New CSS Rule button ( ) at the bottom of the CSS
panel.

The New CSS Rule dialog appears (Figure 8).

FIGURE 8

The New CSS Rule dialog lets you define styles either in a new style
sheet or only in the page you’re working on. A new style sheet is a
much better choice because it can be reused elsewhere.
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3. In the New CSS Rule dialog, set the following:

a. For Selector Type, select Class.

b. In the Name field, enter siteHeader.

c. For Define in, choose (New Style Sheet File).

4. Click OK.

The Save Style Sheet File As dialog opens so you can save the style
sheet that will contain the siteHeader style.

5. Name the style sheet mystylesheet.css, navigate to the folder
where you’re keeping your work, and click Save.

The CSS Rule Definition dialog opens siteHeader.

6. For now, limit yourself to the Type category and set the following:

• Font: Arial, Helvetica, sans-serif

• Size: large

• Weight: bold

• Color: red (click the Color button and choose red from the pop-
up palette.)

7. Click OK.

You won’t see any changes to your text yet because you haven’t yet
applied siteHeader. However as Figure 9 shows, Dreamweaver has
updated the CSS panel.

Depending on the version of Dreamweaver and how it’s set up,
the style sheet may open. In it, Dreamweaver has translated what
you’ve entered into a format that browsers understand. You can leave
it open if you wish; Dreamweaver continues to update it as you create
new styles whether or not you can see the file. If you close it, Dream-
weaver will ask you to save it; do so.
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FIGURE 9

The CSS panel automatically updates whenever you add a new style.
On a Mac, click the triangle to the left of a style sheet name to show
or hide the styles it contains. On Windows, click the small box with
the plus or minus sign.

Format text with the new siteHeader style:

1. If the Property inspector isn’t already open, open it by choosing
Window > Property Inspector.

2. Select the first line of text on the page (“Main Heading”).

3. In the Property inspector, click the Style pop-up menu to see a
preview of siteHeader (Figure 10). Then, choose siteHeader.

FIGURE 10 The Property inspector’s Style
pop-up menu applies a style
you’ve defined to the text you’ve
selected.

Dreamweaver displays the text on your page using the attributes you
defined for siteHeader.
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Create a subhead style and use it to format a subheading:

1. Click the New CSS Rule button ( ) to open the New CSS Rule
dialog. Then set the following:

• For Selector Type, select Class.

• In the Name field, enter subhead.

2. Click OK.

NOTE Dreamweaver doesn’t ask you to save a new style sheet; it assumes
that you want new styles saved in the current one until you explicitly
say otherwise.

3. The CSS Rule Definition dialog opens subhead. Again, limit
yourself to the Type category and set the following:

• Font: Arial, Helvetica, sans-serif

• Size: medium

• Weight: normal

• Color: red (click the Color button and pick red.)

4. Click OK.

Again, you won’t see changes to the text because you haven’t
yet applied subhead. However, Dreamweaver has updated the
CSS panel (click the All button, if necessary, and to use the control
next to the name of the style sheet to show or hide its styles).

5. Select the second line of text on the page (“Subhead”), and in the
Property inspector, choose subhead from the Style pop-up menu.

Dreamweaver formats the text with the attributes in subhead.

Create a bodytext style and use it to format text:

Now that you’ve defined the two heading styles, you are nearly done,
but I’d like you to define one more style, called bodytext, so that you
can lock in your knowledge of how to make styles and—in a moment—
get a feel for how useful they can be. Use the following attributes:

• Font: Arial, Helvetica, sans-serif

• Size: small
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• Weight: normal

• Color: black (click the color button and choose black from the pop-
up palette.)

Now you can apply bodytext to the third line of text on the page.

Edit Your Styles
Making changes to your styles is straightforward, and if you are
following along with the tutorial in this section, I suggest that you
change each style in turn, so you can get a little practice:

1. In the CSS panel, select the style you wish to change. (If you see
only the style sheet, click the control—the triangle or the plus
sign—to reveal all the styles it contains.)

2. At the lower right of the CSS panel, click the Edit Style button ( )
to open the CSS Rule Definition dialog for the style you selected.

3. As you did when you created the style, set various attributes (for
example, change the font family and size), and then click OK.

Dreamweaver immediately updates your Web page to reflect the
changes you made to the style.

Apply Your Styles to Other Pages
At this point, you may be wondering if what you’ve just done has any
real-world advantage. After all, you had to stop working on your page,
save a style sheet, create a bunch of styles, and then apply them to dif-
ferent parts of your text. Yes, changing the style definition automatic-
ally changed this page, but did it improve your life as a designer?

You bet it did.

To see that, repeat the process of creating a new page and putting
some demonstration text in it (don’t merely save the page you’re
working on under a new name):

1. Create a new document as a basic HTML page.

2. Choose File > Save, navigate to the folder you’ve been using, and
save the file as mythirdpage.html.
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3. Enter (or paste in) the following three lines of text, each separated
by a carriage return:

Main Heading
Subhead
Here is some body text.

4. In the CSS panel, at the bottom, click the Attach Style Sheet button
( ). (If the CSS panel isn’t open, choose Window > CSS Styles).

5. In the Attach External Style Sheet dialog, click the Browse button,
and open mystylesheet.css.

6. From the “Add as” set of radio buttons, select Link. Then click OK.

You’ll see mystylesheet in the CSS Panel, which means it’s now
linked to my file, mythirdpage.html.

7. Use the Style pop-up menu on the Property inspector to apply the
styles in mystylesheet to the text in this document.

Because both pages now have the same styles attached to their text,
you’re beginning to leverage the work you put in creating styles in a
style sheet. But you have one more trick to do—to change how text
looks in both pages without doing anything directly to those pages:

1. In the CSS panel, select the style you wish to change.

2. Click the Edit Style button ( ).

The CSS Rule Definition dialog for the style you selected opens.

3. As you did when you created the style, set various attributes (for
example, change the font family and size), and click OK.

Dreamweaver immediately updates both Web pages to reflect the
changes you made to the style.

Caveat: When you quit, Dreamweaver asks you to save any
changes you made to your style sheet, as well as to your Web pages.
Obviously, save the updated version if it’s what you want.

Now that you’ve followed the steps to learning the basics of using
styles in Dreamweaver, I recommend that you take a few minutes to
edit your styles again and explore the other categories in the CSS Rule



Page 30

definition dialog (select a style and click the Edit Style button). Of
course, it’s easy to go overboard and style your text into mush. But for
the moment, leave good taste behind and experiment with what CSS
makes possible. I suggest that you also create a few more dummy
pages, link them to your style sheet, and see the magic when changes
to that style sheet show up on all your pages.

See Why CSS Is Important
Now think ahead to a Web site you’d like to build, not with two
pages but ten or a hundred or a thousand. As long as you’ve linked
those pages to the same style sheet, any change you make to a style
contained in that style sheet immediately takes effect on all those
pages. You won’t have to open each page, find each instance of text,
and apply the change—instead, browsers use the updated style sheet
to render all your pages.

That’s powerful not only because you save time and reduce errors
but because it gives you the freedom to experiment painlessly. Would
your page look better with the Trebuchet font instead of Arial? Would
burnt umber be a better color choice than sienna for a header? Would
legibility suffer if you reduced font size from small to x-small? Just
as spreadsheets let you play what-if with numbers, CSS lets you play
what-if with Web pages. Or to put it another way, CSS frees you to do
what you do best—think, imagine, design—by letting computers do
what they do best.

Warning: a shortcut you shouldn’t take! You can also format
a page without performing the steps described earlier in this section.
If you choose Modify > Page Properties, the Page Properties dialog
appears, into which you can conveniently set the appearance of your
font, links, and headings. Dreamweaver then generates the appro-
priate CSS.

The catch is that it embeds the CSS into the page, rather than creat-
ing a separate style sheet. And that means that you must repeat
the process for every page—and then edit every page if you want
to change something. That pretty well defeats the point of CSS; it’s
far better to create a style sheet once and link it to as many pages
as you like.


