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chapter

14

As the dull-sounding name site management implies, organizing and tracking 
your Web site’s files is one of the least glamorous, most time-consuming and 
error-prone aspects of being a Web designer. On the Web, your site may look 

beautiful, run smoothly, and appear to be a gloriously unified whole, but behind the 
scenes it’s nothing more than a collection of varied files—HTML, images, Cascading 
Style Sheets, Flash movies, and so on—that must all work together. The more files 
you have to keep track of, the more apt you are to misplace one. A single broken 
link or missing graphic can interfere with the operation of your entire site, causing 
personal—even professional—embarrassment. 

Fortunately, computers excel at tedious organizational tasks. Dreamweaver’s site man-
agement features take care of the complexities of dealing with a Web site’s many files, 
freeing you to concentrate on the creative aspects of design. In fact, even if you’re a 
hand-coding HTML junkie and you turn your nose up at all visual Web page editors, 
you may find Dreamweaver worth its weight in gold just for the features described in 
this chapter and the next two. 

Where the first three parts of this book describe how to create, lay out, and embellish 
a Web site, this part offers a bird’s-eye view of the Web production process as you see 
your site through to completion and, ultimately, upload it to the Internet. 

To get the most out of Dreamweaver’s site management features, you need to be 
familiar with some basic principles for organizing Web files, as discussed in the next 
section.
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Structuring a Web Site
When you build a Web site, you probably spend hours providing your visitors with 
carefully planned links, helpful labels, and clear, informative navigation tools. You 
want your site architecture to make it easy for them to understand where they are, 
where they can go, and how to return to where they came from (see Figure 14-1). 
Behind the scenes, it’s equally important to organize your site’s files with just as much 
clarity and care, so that you can find your way around when updating or modifying 
the site later. And, as on your home computer, a Web site’s main organizational tool 
is the humble folder. 

You organize files on your computer every day, creating, say, a folder called Personal, 
within which are folders called Financial Planning and Vacation Pictures. Inside 
the Vacation Pictures folder, you have separate folders for your memories of Maui, 
Yosemite, and the Mall of America. 

The same principle applies to the folders that make up a Web site: All Web sites have 
one primary folder—the root folder—that holds all of the site’s Web pages, graphics, 
and other files used in the site. The root folder usually contains additional folders for 
further subdividing and organizing the site’s files. 

Structuring a  
Web Site

Figure 14-1:
A good site has 
an easy-to-
understand 
structure. Con-
tent is divided 
into logical 
sections, and a 
prominent navi-
gation bar—the 
column of white 
buttons on 
the left in this 
image—gives 
visitors quick 
access to infor-
mation. When 
building a site, 
this “informa-
tion architec-
ture” provides 
a useful model 
for naming and 
creating the 
folders that will 
hold the site’s 
files.
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A good structure (see Figure 14-2) speeds up the production and maintenance of 
your site by providing quick access to whatever graphic, style sheet, or Flash movie 
you’re looking for. But don’t fall into the trap of becoming so obsessed that you put 
every graphic or Web page you create in its own separate folder; creating a structure 
for the files in a site should make your job easier, not harder.

Tip: If you already have a Web site that suffers from lack of organization, it’s not too late. Dreamweaver 
can help you reorganize your files quickly and accurately. Take the following rules to heart and then turn to 
“Organizing Site Files” on page 465, to learn how Dreamweaver can knock your current site into shape.

Here, then, are some guidelines for effective site organization:

 • Plan for future growth. Like ever-spreading grapevines, Web sites grow. Today 
you may only have enough words and pictures for ten Web pages, but tomorrow 
you’ll put the finishing touches on your new 1,000-page online catalog. It may 
seem like overkill to create a lot of folders for a small site, but better to start with 
a solid structure today than find yourself knee-deep in files tomorrow. 

For instance, it’s useful to create additional folders for graphics files that appear 
within each section of the site. If a section of your site is dedicated to promot-
ing your company’s products, create a folder called Products for storing product 
Web pages. Create an additional folder called Images to store the pictures of those 
products. Then, when you add more products or images, you know right where 
to put them.

Structuring a  
Web Site

Figure 14-2:
Here’s a sample structure for a Web site. The root 
(main) folder, cosmo, holds all of the pages in the 
site. The home page, index.html, is in the root folder, 
while other pages are in subfolders—one folder for 
each section. 

The home page uses lots of graphics that don’t 
appear anywhere else on the site; a folder named 
images_home helps keep those in order. In addi-
tion, since many pages share the same navigation 
elements, logos, and other graphics, there’s a folder 
called images_global. Also notice that the Classifieds 
folder (like the folder for each section of the site) 
has its own default page, here called  
index.html, and can contain additional subfolders 
(see the box on page 457).

Home page

One section
of the site

Graphics used
throughout the site

Graphics used on
the home page
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Note: While you can start with no organization plan and later use Dreamweaver to bring it all into shape 
(page 465), you may run into unforeseen problems that way if your site is already on the Internet. If your site’s 
been up and running for a while, search engines may have indexed your site, and other Web sites may have 
linked to your pages. If you suddenly rearrange the pages of your site, those cherished links from the outside 
world may no longer work, and people who try to access your site from a search engine may be foiled.

 • Follow the site’s architecture. Take advantage of the work you’ve already done in 
organizing the content on your site. For instance, the National Exasperater’s site 
content is divided into five main sections: Headlines, Horoscopes, Quiz, Store, and 
Archives, as shown in Figure 14-1. Following this architecture, it makes sense to 
create folders—headlines, horoscopes, and so on—in the site’s root folder for each 
section’s respective Web pages. If one section is particularly large, add additional 
subfolders. 

 • Organize files by type. After you create folders for each section of your site, you’ll 
probably need to add folders for storing other types of files like graphics, Cascading 
Style Sheets, external JavaScript files, and PDF files. Most sites, for instance, make 
extensive use of graphics, with several graphics on each page. If that’s the case for 
you, then you need to file those images neatly and efficiently.

One way to organize your graphics is to create a folder for images that appear on 
your home page and another for images that appear elsewhere in the site. Often, 
the home page is visually distinct from other pages on the site and contains graph-
ics that are unique to it. You can create a folder—images_home, for example—in 
the root folder for images that only appear on the home page. Create another 
folder—images_global, for example—to store graphics that all or most of the 
pages use, such as the company logo, navigation buttons, and other frequently 
used icons. When you add images to other pages of your site, you’ll know to look 
for them in this folder. 

Naming Your Files
The rules for naming files in Windows and Macintosh are 
fairly flexible. You can use letters, numbers, spaces, and even 
symbols like $, #, and ! when naming folders and files on 
these operating systems. 

Web servers, on the other hand, are far less accommodat-
ing. Because many symbols—such as &, @, and ?—have 
special significance on the Web, using them in file names 
can confuse Web servers and cause errors. 

The precise list of no-no’s varies from Web server to Web 
server, but you’ll be safe if you stick to letters, numbers, the 

hyphen (-), and the underscore (_) character when naming 
files and folders. Stay away from spaces. File names like 
company logo.gif or This company’s president.html probably 
won’t work on most Web servers. Replace spaces with under-
scores or inner caps—company_logo.gif or companyLogo.
gif—and remove all punctuation marks. 

Sure, some operating systems and Web servers permit 
strange naming conventions, but why take the chance? 
Someday you may need to move your site to another, less 
forgiving Web server. Play it safe: keep your file names 
simple.

UP TO SPEED
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 • Use understandable names. While file names like 1a.gif, zDS.html, and f.css are 
compact, they aren’t very explanatory. Make sure file names mean something. 
Clear, descriptive names like site_logo.gif or directions.html will make it a lot easier 
for you to locate files and update pages.

This principle is especially important if you work as part of a team. If you’re 
constantly explaining to your coworkers that 345g.gif is the banner for the home 
page, changing the file name to home_banner.gif could save you some aggravation. 
There’s a tradeoff here, however, as long file names can waste precious bytes. For 
instance, a name like this_is_the_image_that_goes_in_the_upper_right_corner_ 
of_the_home_page.gif is probably not a good idea. 

It’s also helpful to add a prefix to related files. For example, use nav_ at the begin-
ning of a graphic name to indicate that it’s a navigation button. In this way, you 
can quickly identify nav_projects.gif, nav_quiz.gif, and nav_horoscopes.gif as graph-
ics used in a page’s navigation bar. As a bonus, when you view the files on your 
computer or in Dreamweaver’s Files panel (see Figure 14-5), they’ll appear neatly 
sorted by name; in other words, all the nav_ files will cluster together in the file 
list. Likewise, if you have rollover versions of your navigation graphics (page 132), 
give them names like nav_projects_over.gif, or nav_horoscopes_high.gif, to indicate 
that they are the highlighted (or over) state of the navigation button. (If you use 
Fireworks, its button creation tools automatically use names like nav_projects_f1.gif 
and nav_projects_f2.gif to indicate two different versions of the same button.)

All Those Index Pages
Why are so many Web pages named index.html (or index.
htm)?

If you type a URL like www.missingmanuals.com into a 
Web browser, the Missing Manuals home page opens on 
your screen. But how did the Web server know which page 
from the site to send to your browser? After all, you didn’t 
ask for a particular Web page, like www.missingmanuals.
com/about.html.

When a Web server gets a request that doesn’t specify a 
particular Web page, it looks for a default Web page—often 
named index.html or index.htm. It does the same thing 
even when the URL you’ve typed specifies (with a slash) a 
folder inside the site root, like this: www.missingmanuals.
com/cds/. In this case, the Web server looks for a file called 
index.html inside the cds folder, and—if it finds the file—sends 
it to your Web browser. 

If the Web server doesn’t find an index.html file, two things 
can happen, both undesirable: The Web browser may display 
either an ugly error message or a listing of all the files inside 
the folder. Neither result is user-friendly.

While your site will still function without this step, it’s good 
form to give the main Web page inside each folder in your 
site the proper default page name. Web servers use different 
names for these default pages—index.html or default.html, 
for example—so check with your Web server’s administrator 
or help desk. In fact, any page name can be used as a default 
page, as long as you set up your Web server to look for the 
correct default name. So if you’re creating a dynamic site like 
those discussed in Part 6, you can set up a server to look for 
a dynamic page like index.asp, or index.php as the default 
page. On many Web servers, multiple default page names 
are specified, so if it doesn’t find a file named index.html, it 
might then look for a file called index.php. 

FREQUENTLY ASKED QUESTION
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Tip: If you use a Mac, you might not be familiar with the three or four letters that follow Web file names. 
These letters, or file name extensions, tell Windows computers what program should open the file. They’re 
used universally as part of all Web files’ names. 

The trick is that Windows and Macintosh computers use slightly different extensions. For example, in Windows, 
Web page names are often followed by .htm, whereas the Mac uses .html. In most cases, the Windows and 
Macintosh extension versions are interchangeable. The one exception is JPEG files: Some Windows computers 
don’t understand the Mac extension .jpeg, so it’s best to stick to the Windows extension, .jpg. 

When you save a page, Dreamweaver proposes adding .htm, but you can manually change the extension to 
.html. If you want Dreamweaver to use .html automatically instead, see the box below.

 • Be consistent. Once you’ve come up with a system that works for you, follow it. 
Always. If you name one folder images, for instance, don’t name another graphics 
and a third pretty_pictures. And certainly don’t put Web pages in a folder named 
images, or Flash movies in a folder named style_sheets. 

In fact, if you work on more than one Web site, you may want to use a single nam-
ing convention and folder structure for all of your sites, so that switching among 
them will go more smoothly. If you name all your graphics folders images, then 
no matter what site you’re working on, you already know where to look for GIFs 
and JPEGs.

Getting a New Extension 
When you create a new Web page in Dreamweaver and then 
save it, Dreamweaver automatically adds the file extension 
.htm (if you don’t specify one yourself). For example, if you 
create a new page, choose File→Save and type about in the 
file name box of the Save As dialog box, Dreamweaver saves 
the file as about.htm. If you prefer .html, because you’ve 
always done it that way or you don’t like the Windows-centric 
three-letter extension names, you can bend Dreamweaver 
to your will. It just takes a little extra work. 

Your best bet is to launch a text editor other than Dream-
weaver, such as BBEdit, Homesite, Notepad, or Text Edit. 
Then use that program to open a file called Dreamweaver 
MX 2004→Configuration→Document Types→MMDocu-
mentTypes.xml. (On Windows, you’ll probably find your 
Dreamweaver MX 2004 in the Program Files→Macromedia 

folder; on a Mac, try Applications→Macromedia→Dream-
weaver MX 2004.) 

Before you go any further, close Dreamweaver and, in 
your text editor, make a backup of the MMDocument-
Types.xml file to be on the safe side. On the third line of 
the document—it begins with <documenttype id="HTML" 
internaltype="HTML"—look for the word winfileextension 
or macfileextension (depending on your operating system). 
You’ll see something like this: winfileextension="htm,html
,shtml,shtm,stm,tpl,lasso,xhtml". This code indicates which 
extensions Dreamweaver recognizes as HTML pages. Reverse 
htm and html in the list like this: html,htm,shtml… and so on. 
Save and close the file. Launch Dreamweaver and create a 
new HTML document. Save the file without adding an exten-
sion to it. Voila. Dreamweaver adds .html to the end.

POWER USERS’ CLINIC
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Tip: Put only files that will go on your Web site in the root folder and its subfolders. Keep your source 
files—the original Photoshop, Fireworks, Flash, or Word documents where you created your content—stored 
elsewhere on your computer. This way, you’re much less likely to accidentally transfer a 14.5-megabyte 
Photoshop file to your Web server (a move that would not gain you friends in the IT department). But if 
you insist on keeping all those files together with your Web site files, check out Dreamweaver’s cloaking 
feature. Using it, you can prevent certain file types from being transferred to your Web server when using 
Dreamweaver’s FTP feature. 

Defining a Site
Organizing and maintaining a Web site—creating new folders and Web pages; 
moving, renaming and deleting files and folders; and transferring pages to a Web 
server—can require going back and forth between a couple of different programs. 
With Dreamweaver’s site management features, however, you can do it all from within 
one program. But in order to take advantage of these features, you must first define 
the site; in other words, give Dreamweaver some basic information about it. 

Defining the site involves showing Dreamweaver which folder contains your Web site 
files (the root folder) and setting up a few other options. You’ve already learned how 
to do this site-building using Dreamweaver’s Site Definition Wizard (page 26). But 
for fine-tuning your settings, it’s time to get to know the advanced Site Definition 
window. 

Start by choosing Site→Manage Sites to open the Manage Sites window (Figure 
14-3). This window lets you create, edit, duplicate, delete, export, and import your 
Dreamweaver sites. (It was called the Edit Sites window in earlier incarnations of 
Dreamweaver.) 

When you click the New button to create a new site, a small menu appears (also new 
in Dreamweaver MX 2004). It lets you choose either Site or FTP & RDS Server (see 
Figure 14-3). The Site option, which is the choice you’ll use most often, lets you define 

Figure 14-3:
The Manage Sites window (known as the Edit 
Sites window in earlier version of Dreamweaver) 
includes two new options for creating a new site. 
In addition to the traditional setup where the site 
files you’re working on reside on your computer, 
you can also set up FTP or RDS server sites. This 
feature lets you work directly on live files via 
FTP or Cold Fusion’s RDS (Remote Development 
Services). 
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a traditional Dreamweaver site—a site where working files reside on your computer. 
The FTP & RDS Server option lets you create a connection to a live Web server either 
using FTP or Cold Fusion’s RDS (Remote Development Services). Neither of these 
methods, though, lets you take advantage of Dreamweaver’s excellent site management 
tools (discussed in this and the following chapters). In addition, since you’re working 
on live files on the server, you run the risk of making a serious and all-too-visible 
mistake on a live Web page visited by thousands of people a day. 

Note: If you do want to use FTP or RDS to work directly on live site files, choose the FTP & RDS Server op-
tion when creating a new site. You then enter the same information you would when creating a connection 
to a remote FTP or RDS server, as discussed on page 514.

For setting up a regular Dreamweaver site, choose Site from the New menu. The 
Site Definition window appears (see Figure 14-4). Click the Advanced tab to access 
Dreamweaver’s advanced settings. There are eight categories of information for your 
site, but to get up and running, you need to provide information only for the first cat-
egory: Local Info. (The remaining categories are discussed in Chapters 15 and 16.)

Here are the options on the Local Info tab:

Site name
Into the Site Name field, type a name that briefly identifies the site for you—and 
Dreamweaver. This is the name that appears, among other places, on the Site pop-

Figure 14-4:
The Basic tab of the 
Site Definition window 
provides a simple 
method for new users 
to set up a Web site. 
But experienced users 
can take advantage 
of the greater options 
available under the 
Advanced tab shown 
here. The eight catego-
ries listed on the left 
side of the window are 
discussed in this and 
the next two chapters. 
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up menu on the Files panel (Figures 14-6 and 14-7), so that you can tell what site 
you’re working on.

Local root folder
Identify your site’s local root folder—the folder that contains all files belonging to 
your site—by clicking the folder icon to the right of the “Local root folder” field. The 
procedure is described on page 28. (Also see the box on page 462 for more informa-
tion on local root folders.)

All of Dreamweaver’s tools for managing your sites’ files rely on the local root folder. 
Once you’ve defined a site, you see all of its files listed in the Files panel. Make sure to 
turn on the “Refresh local file list automatically” checkbox so that new files—graph-
ics, Web pages, and so on—automatically appear in the Files panel as you add them. 
Alternatively, click the Refresh button (Figure 16-7) each time you want to see your 
recent changes in the site files list.

Default images folder
For a graphic image to work properly on the Web, you can’t just add it to a Web page 
(Chapter 5); you also have to store a copy of the graphics file in the local root folder 
or one of its subfolders. In other words, if you link to a graphic that’s sitting on your 
computer’s hard drive outside of the root folder, the Web browser will never find it. 

Dreamweaver offers a feature that puts images in the right place even if you forget. 
When you add a stray graphics file to a page in your site, the program automatically 
copies the file into your default images folder. In fact, even if you drag a graphic from 
your desktop onto a Web page in progress, Dreamweaver copies the file to the default 
images folder without missing a beat. 

The process of choosing the default images folder is the same as selecting a local root 
folder. Click the folder icon and select the proper folder, which can be an existing 
folder in your local root or a new one you create on the spot. (If you’re following the 
process described on page 454, select the images_global folder here.)

Bringing Your Own Web Site
I already have a Web site. Will Dreamweaver work with 
it?

Yes. In fact, Dreamweaver’s site management features are 
an invaluable aid in organizing the files of an existing site. 
As you can read in “Organizing Site Files” on page 465, you 
can use Dreamweaver to rearrange, rename, and reorganize 
files—tasks that are extremely difficult and time-consuming 

to do by hand. Furthermore, Dreamweaver lets you clean 
up and reorganize a site without breaking links. So Dream-
weaver can be just as useful for working with a completed 
site as it is for creating one from scratch.

To work on an existing site, first save a copy of all site files on 
your computer, all in one folder. When defining the site (see 
page 459), choose this folder for the local root folder. 

FREQUENTLY ASKED QUESTION
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HTTP address
If you use absolute URLs to link to pages within your site (page 101), you must fill 
out the “HTTP address” field in order for Dreamweaver’s link management features 
to work properly. Type your site’s full URL beginning with http://. Dreamweaver uses 
this address to check for broken links within your site and to correctly rewrite links 
if you move pages around. 

Note: This step is necessary only if you use absolute URLs to link to pages, graphics, or other supplemental 
files within your site. For example, maybe your Web master directs you to link a form to http://www.yourdo-
main.com/cgi/formscript.php instead of using a document relative link. In this case, you’d type http://www.
yourdomain.com/ in the HTTP Address box. In most cases, if you’re doing all the development with Dream-
weaver, you won’t run into this situation, and you can leave the HTTP address field empty.

Cache
The cache is a small database of information about the files in your site. It helps 
Dreamweaver’s site management features work more efficiently; leave this checkbox 
turned on.

Once you’ve provided the local information for your site, click OK to close the Site 
Definition window and begin working. 

Editing or Removing Defined Sites
Sometimes you need to edit the information associated with a site. Perhaps you want to 
rename the site, or you’ve reorganized your hard drive and moved the local root folder 
to a different location, and you need to let Dreamweaver know what you’ve done. 

Local vs. Remote Root Folders
A root folder is the main hold-everything folder for your site. 
It contains every piece of the site: all Web page documents, 
graphic images, CSS style sheets, flash movies, and so on. 

The word “root” implies that this is the master, outer, 
main folder, in which there may be plenty of subfolders. 
Remember that, in most cases, your Web site exists in two 
locations: on your computer as you work on it, and on the 
Internet where people can enjoy the fruits of your labor. 
In fact, most Web sites in the universe live in two places at 
once—one copy on the Internet, the original copy on some 
Web designer’s hard drive.

The copy on your own computer is called the local site or the 
development site. Think of the local site as a sort of staging 
ground, where you build your site, test it, and modify it. 

Because the local site isn’t on a Web server, and the public 
can’t see it, you can freely edit and add to a local site without 
affecting the pages your visitors are viewing, meanwhile, on 
the remote site. The root folder for the version of the site on 
your computer, therefore, is called the local root folder.

When you’ve added or updated a file, you move it from the 
local site to the remote site. The remote, or live, site mirrors 
the local site. Because you create it by uploading your local 
site, it has the same organizational folder structure as the 
local site and contains the same polished, fully functional 
Web pages. However, you leave the half-finished, typo-rid-
den drafts on your local site until you’ve perfected them. 
Chapter 16 explains how to use Dreamweaver’s FTP features 
to define and work with a remote site.

UP TO SPEED
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To edit a site, open the Manage Sites dialog box (choose Site→Manage Sites or, in the 
Files panel, choose Manage Sites from the Site pop-up menu) and double-click the 
name of the site you want to edit. The Site Definition window opens (Figure 14-4). 
Now you can type a new name in the Site Name box, choose a new local root folder, 
or make any other changes. Click OK to close the dialog box when you’re done.

Tip: If you want to edit the current site’s information, there’s a shortcut. In the Files panel (Figure 14-6), just 
double-click the name of the site in the Site menu. (Mac users need to click once to select the name in the 
menu, then double-click to open the Site Definition window.)

Once you’ve finished a site and are no longer working on it, you may wish to remove 
it from Dreamweaver’s list of sites. To delete a site from the list, open the Manage 
Sites dialog box as described above, click to select the site you wish to delete, and 
click Remove. 

A warning appears telling you that this action can’t be undone. Don’t worry; deleting 
the site here doesn’t actually delete the site’s images, Web pages, and other files from 
your computer. It merely removes the site from Dreamweaver’s list of defined sites. 
(You can always go back and define the site again, if you need to, by following the 
steps on page 459.) Click Done to close the Manage Sites window.

Tip: If you do, in fact, want to delete the actual Web pages, graphics, and other site components, you can 
either switch to the desktop (the Finder or Windows Explorer, for example) and delete them manually, or 
delete them from within Dreamweaver’s Files panel, described in this chapter.

Exporting and Importing Sites
When you define a site, Dreamweaver stores that site’s information in its own private 
files. If you want to work on your site using a different computer, therefore, you must 
define the site again for that copy of Dreamweaver. In a design firm where several 
people might be working together on many different sites, that’s a lot of extra setup. 
In fact, even if there’s just one of you working on two computers, duplicating your 
efforts is a pain. 

So that you can put your time to better use, Dreamweaver MX lets you import and 
export site definitions. For example, you can back up your site definition files—in case 
you have to reinstall Dreamweaver—or export a site definition for others to use. 

Note: Unfortunately, you can only import or export one site at a time. So if you have a lot of sites and want 
to back up their information, grab some coffee and get clicking. (Windows users have another option; see 
the Note on page 464.)

To export a site definition: 

 1. Choose Site→Manage Sites.

The Manage Sites window appears listing all the sites you’ve defined.

Structuring a  
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 2. Select a site from the list, and then click Export.

If the site definition includes remote site information (page 514), you’ll see a 
panel called Export Site (Figure 14-5). If you’re simply making a backup of your 
site definition because you need to reinstall Dreamweaver, select the “Back up my 
settings” radio button. (The other option, “Share settings,” is useful when, for ex-
ample, your local root folder is on the C: drive, but it’s on the E: drive on someone 
else’s computer, so your setup information doesn’t apply to them. It’s also handy 
when you don’t want to give someone else your user name and password to the 
Web server.)

 3. Click OK. 

The Export Site panel appears. 

 4. In the Export Site panel, specify where you want to save the file and give it a 
name.

If you’re merely making a backup, saving the file to that site’s local root folder is 
a good choice. 

Note: If you use Windows, a helpful utility called DW-Exporter can let you export all of your site definitions 
at once—a great timesaver when backing up your site. In fact, this utility can back up lots of important data, 
including serial numbers and Dreamweaver’s configuration folder. As of this writing, a version for MX 2004 
isn’t available, but the developer promises one soon. For more information, visit http://mm-exporter.joexx.
de/index_en.php.

Once you have a site definition file, you can import it into any version of Dreamweaver 
MX as follows:

 1. Choose Site→Manage Sites.

The Manage Sites panel appears. 

 2. Click Import.

The Import Site panel appears. Navigate to a site definition file—look for a file 
ending in .ste. Select it, and then click OK. 

Figure 14-5:
This dialog box 
lets you back up 
your settings, 
or share them 
(minus your login 
information) with 
other people.
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If you’re importing the site definition to a computer other than the one you used 
to export the site, you may need to perform a few more steps. If Dreamweaver can’t 
locate the local root folder in the site definition file, it will ask you to select a local 
root folder on the new computer, as well as a new default images folder.

Organizing Site Files
Once you’ve defined your local site, Dreamweaver helps you organize your files, create 
folders, and add new Web pages to your site using the Files panel as your command 
center. To open the Files panel, choose Window→Files, or just press F8. 

In its most basic incarnation, the Files panel displays the files in the current site’s lo-
cal root folder. This list looks and acts just like Windows Explorer or the Macintosh 
Finder; you see names, file sizes, and folders. You can view the files inside a folder by 
clicking the + (4) symbol next to the folder (or simply by double-clicking the folder). 
Double-click a Web page to open it in Dreamweaver.

Tip: You can open certain types of files in an outside program of your choice by defining an external editor 
for that file type. For example, you can tell Dreamweaver to open GIF files in Fireworks, Photoshop, or another 
image editor. (See “Setting Up an External Editor” on page 126 for more on this feature.)

You can view your site’s files in four different ways using the View pop-up menu 
(shown in Figure 14-6):

 • Local View shows the files in your local root folder. 

 • Map View shows a map of your site (see page 471).

 • Remote View shows files on the Web server in the remote root folder (page 462). 
Of course, before you’ve posted your site on the Web, this list is empty. Information 
appears here only after you’ve set up a connection to a remote root folder (page 
514) and connected to a Web server.

 • Testing Server view is useful when you’re creating the dynamic database-driven 
sites discussed in Part 6 of this book. No files appear in this view until you’ve set 
up a testing server (page 656) and connected to it.

The Windows Files Panel
If you choose to expand the Files panel, so you can see a side-
by-side view of both the remote site files and local site files, 
click the Expand/Collapse button (see Figure 14-7). The Files 
panel fills the screen. The obvious drawback is that you can’t 
work on a Web page while the Site window is maximized, 
because you can’t even see it. Click the Expand/Collapse 
button again to minimize the Files panel and gain access to 
your document window. 

To get around this limitation, you can undock the Files panel: 
Grab the Files panel group by its grip—the column of dots 
to the left of the word Files—and drag it toward the middle 
of the screen. (Stay away from the edges of the screen. This 
may simply redock the panel group.) The panel group then 
becomes a floating panel. You’re now free to resize the Files 
panel even after expanding it.

FOR WINDOWS PCS
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Tip: In Windows, you can quickly hide and show the panel groups by clicking the Show/Hide Panels button at 
the left edge of the panel groups (see Figure 14-6). On small monitors, hiding panels can give you breathing 
room to work on your Web pages. You can also resize the panel groups by dragging this button left or right. 
And pressing F4 hides (or shows) all panels including the Property inspector and Insert bar.

Adding New Folders and Files
The Files panel provides a fast way of adding blank Web pages to your site. With 
one click, you can create a new page in any folder you like, saving several steps you’d 
otherwise have to perform using the File menu. 

Adding files
To create a new, blank Web page, open the Files panel using one of the methods 
described on page 465, then right-click (Control-click) a file or folder in the Files 
panel. 

Figure 14-6:
The Files panel, logically enough, lists files in the 
currently active Web site. A list of all the Web sites 
you’ve defined in Dreamweaver appears in the Sites 
pop-up menu; to work on a different site, select its 
name. 

You can use the Files panel to transfer files back 
and forth between your local and remote site, as 
described on page 522.

Sites menu

File-transfer tools View menu
Expand/
Collapse

Site files in
local root
folder

Show/Hide
Panels
(Windows)
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In the contextual menu that appears, choose New File. Dreamweaver creates a new, 
empty Web page. (Actually, the page doesn’t have to be empty; you can edit the file 
Dreamweaver uses as its default new page, as described in the box below.)

Note: The type of file Dreamweaver creates depends on the type of site you’re creating. For a plain HTML 
site, Dreamweaver creates a blank HTML page. However, if you’re building a dynamic database-driven site 
like those described in Part 6, Dreamweaver creates a blank page based on the type of server model you’ve 
selected. For example, if you’re building a site using PHP and MySQL, the page will be a blank PHP page 
(named untitled.php). 

The new file appears in the Files panel with a highlighted naming rectangle next to 
it; type a name for the page here. Don’t forget to add the appropriate extension (.htm 
or .html) to the end of its name.

Figure 14-7:
The Expand/Collapse button 
maximizes the Files panel to fill the 
monitor and lets you display two views 
simultaneously. This way, you can look 
at both a map of the site and the files 
in the local root folder, say, or view 
both the remote and local sites at the 
same time. 

Local Files always appear on the 
right. Which view appears on the left 
side—Remote, Testing, or Site Map—de-
pends on which view you selected 
before clicking the Expand button. 

Testing server Local site

Changing the Default New Page
Whenever you make a new Web page—for example, by 
choosing File→New or by right-clicking (Control-clicking) 
an existing file in the Files panel—Dreamweaver gives you a 
blank, white document window. But what if you always want 
your pages to have gray backgrounds, or you always want to 
include a link to the same external style sheet?

Every new Web page you create is actually an untitled copy of 
a default template document called Default.html. (You’ll find 
it in the Macromedia Dreamweaver MX 2004→Configura-
tion→DocumentTypes→NewDocuments folder.) You can 
open this file within Dreamweaver and edit it however you 
like: change its background color, margins or text color, or 

whatever, so that all subsequent new pages you create inherit 
its settings. Consider making a backup of this file before edit-
ing it, however, so that you can return to the factory settings 
if you accidentally make a mess of it. 

You’ll also notice lots of other files in this folder. Since Dream-
weaver MX can create lots of different file types—Cascading 
Style Sheets, Active Server pages, and so on—you’ll find a 
default blank file for each. You can edit any of these—but 
don’t, unless you’re sure of what you’re doing. You can eas-
ily damage some of the more complex file types, especially 
those that involve dynamic Web sites.

POWER USERS’ CLINIC
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Adding folders
You can add folders to your site directly in Dreamweaver using the Files panel. Just 
right-click (Control-click) a file or folder in the local files list. If you click a file, 
Dreamweaver creates the new folder in the same folder as that file; if you click a folder, 
you get a new folder inside it. 

From the contextual menu, choose New Folder. 

If you crave variety, you can add a folder another way. Select a file or folder in the 
Files panel and then click the contextual menu button (see Figure 14-6) and select 
File→New Folder.

Finally, in the naming rectangle that appears in the Files panel, type a name for the 
new folder.

Moving files and folders
Because the Dreamweaver Files panel looks and acts so much like the Windows Ex-
plorer and Macintosh Finder, you may think it does nothing more than let you move 
and rename files and folders on your computer. You may even be tempted to work 
with your site files directly on the Mac or Windows desktop, thinking that you’re 
saving time. However, when it comes to moving the files and folders in your site, 
Dreamweaver does more than your computer’s desktop ever could. 

In your Web travels, you’ve probably encountered the dreaded “404: File Not Found” 
error. This “broken link” message doesn’t necessarily mean that the page doesn’t exist, 
just that your Web browser didn’t find the page at the location (URL) specified by the 
link you just clicked. In short, someone working on that Web site probably moved or 
renamed a file without updating the link. Because Web site files are interrelated in such 
complex ways—pages link to other pages, which include paths to graphics, which in 
turn appear on other pages—an action as simple as moving one file can wreak havoc 
on an entire Web site. That’s why you shouldn’t drag Web site files around on your 
desktop or rename them in Windows Explorer or the Macintosh Finder.

In fact, moving and reorganizing Web site files is so headache-ridden and error-prone 
that some Web designers avoid it altogether, leaving their sites straining under the 
weight of thousands of poorly organized files. But you don’t have to be one of them: 
Dreamweaver makes reorganizing a site easy and error-free. When you use the Files 
panel to move files, Dreamweaver looks for actions that might break your site’s links 
and automatically rewrites paths of links, images, and other media. 

Note to programmers: If your custom JavaScript programs include paths to images, Web pages, or other 
files in your site, Dreamweaver can’t help you. When you reorganize your site with the Files panel, the program 
updates links it created, but not paths you’ve included in your JavaScript programs. 

Just be sure to do your moving from within Dreamweaver, like this: In the Files panel, 
drag the folder or file into its new folder (see Figure 14-8). To move multiple files, 
Ctrl-click (c-click) each of the ones you want to move, then drag them as a group; to 
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deselect a selected file, Ctrl-click or c-click it again. You can also select one folder or 
file and Shift-click another to select all files and folders in the list between the two.

Note: Close all of your Web documents before reorganizing your files in this way. Dreamweaver doesn’t 
always correctly update links in open files. But if you do end up with malfunctioning links, you can always 
use Dreamweaver’s Find Broken Links tool (page 494) to ferret out and fix any broken links.

When you release the mouse button, the Update Files dialog box appears (Figure 
14-8); just click Update. Dreamweaver updates all the links for you. 

Tip: If you accidentally dragged the file or folder to the wrong location, click Don’t Update. Then drag the 
file back to its original location and, if Dreamweaver asks, click Don’t Update once again. 

Renaming files and folders
Renaming files and folders poses the same problems as moving them. Because links 
include file and folder names, altering a file or folder name can break a link just as 
easily as moving or deleting the file or folder. 

For example, say you’ve created a new site with a home page named home.html. You 
cheerfully continued building the other pages of your site, linking them to home.
html as you went along. But after reading this chapter and checking to find out what 
default file name your Web server requires (see page 457), you found that you need 

Figure 14-8:
Top left: You can move files and folders 
within the Files panel just as you would 
in Windows Explorer or the Macintosh 
Finder. Simply drag the file into (or out 
of) a folder. But unlike your computer’s 
file system, Dreamweaver constantly 
monitors the links between Web 
pages, graphics, and other files. 

Bottom right: If you move a file using 
Windows Explorer or the Finder, you’ll 
most likely end up breaking links to 
that file, or, if it’s a Web page, links in 
that file. By contrast, Dreamweaver is 
smart enough to know when moving 
files will cause problems. The Update 
Files dialog box lets you update links 
to and from the file you’re moving, so 
that your site keeps working.
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to rename your home page file index.html. If you were to rename the file index.html 
using Windows Explorer or the Macintosh Finder, every link to home.html would 
result in a “File not found” error. 

Dreamweaver, on the other hand, handles this potential disaster effortlessly, as long as 
you rename the file in the Files panel instead. To do so, just click the file or folder in 
the Files panel. Pause a moment, and click the name of the file or folder. (The pause 
ensures that Dreamweaver won’t think you just double-clicked the file for editing.)

A renaming rectangle appears; type the new name. Be sure to include the proper exten-
sion for the type of file you’re renaming. For example, GIFs end with .gif, Cascading 
Style Sheets end with .css. Although Dreamweaver lets you name files without using an 
extension, the extensionless files won’t work when you move them to a Web server.

Finally, in the Update Files dialog box (Figure 14-8), click Update. Dreamweaver 
updates all the links to this file or folder to reflect the new name. 

Caution: It bears repeating: never rename or move files and folders outside of Dreamweaver. If you use 
Windows Explorer or the Macintosh Finder to reorganize the files in your site, links will break, images will 
disappear from your pages, and the earth will open underneath your feet. (Well, actually, that last thing 
won’t happen, but it might feel that way when your boss comes in and says, “What’s happened to our Web 
site? Nothing works!”) 

If you’ve edited files outside of Dreamweaver by accident, see page 494 to learn how to find and fix broken 
links.

Deleting files and folders
It’s a good idea to clean up your site from time to time by deleting old and unused 
files. Just as with moving and renaming files, you delete files from the Files panel.

To delete a file or folder, just click to select it in the Files panel and press Backspace or 
Delete. (To select multiple files or folders, Ctrl-click [c-click] them as described on 
page 468.) If the doomed file or folder isn’t referenced by any other page on the site, 
a simple “Are you sure you want to delete this file?” warning appears; click Yes. 

Figure 14-9:
When you delete files in the Files panel, Dreamweaver 
warns you if other pages reference (link to) the file. If 
you click Yes, you’ll need to go back and repair the links. 
Dreamweaver gives you a convenient way to do it—the 
Change Links Sitewide command (see page 500)—and 
reminds you of it in this dialog box.

Structuring a  
Web Site



 chapter 14: introducing site management 471

However, if other files link to the file—or to files within the folder—that you’re de-
leting, then a warning dialog box (Figure 14-9) appears informing you that you’re 
about to break links on one or more pages in your site. The message even lists the 
first few pages that use the file. If you’ve made a mistake, click No to leave your site 
untouched. 

If you’re sure you wish to delete the file, click Yes. And yes, this move does break links 
in all the pages listed. Repairing those links, which usually means linking them to a 
new page, requires a separate step: using the Site→Change Links Sitewide command, 
as described on page 500.

Viewing a Site Map
While the Files panel’s list of files and folders is a great aid in managing those files, it 
doesn’t give you a picture of how your site’s Web pages are linked together. You can 
see that the index.html file in the root folder is the site’s home page, for instance, but 
you can’t see how it relates to the other pages in the site. In other words, you can’t tell 
which pages link to or from it. To see those relationships, you need Dreamweaver’s 
Site→Site Map view. 

The Site Map is a visual guide to the links in a site (see Figure 14-10). An icon repre-
senting the home page appears at the top of the map, and arrows connect the home 
page to icons representing each of the links it contains. As shown in Figure 14-10, 
special icons clearly mark external, broken, and email links. The best way to view 
them is by expanding the Files panel (page 465), which spreads the links out into 
easy-to-read columns. In regular collapsed view, all the links in the map are put into 
a single column, so you need to scroll down to see the each one. Furthermore, the 

Figure 14-10:
The Site Map displays icons for 
each link in a Web site. Symbols 
provide added information 
about the pages: The globe icon 
( ) indicates an external link 
such as http://www.yahoo.com. 
The broken link icon ( ) indi-
cates that the file either doesn’t 
exist or has been misfiled, so 
that the link won’t work. Dream-
weaver also highlights the 
name of the missing file in red. 
For more on finding and fixing 
broken links, see page 494.

External link Broken link
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Site Map does more than just provide a visual overview; it also gives you an easy way 
to rename files and even retitle Web pages.

Setting Up Site Map View
To view a Site Map, you’ll first need to do a little preparation:

 1. Choose Site→Manage Sites (or choose Manage Sites from the Site menu in the 
Files panel). 

The Manage Sites window appears, listing all of your sites. 

 2. Click a site name and click Edit (or just double-click the site name).

The Site Definition window opens. 

If you’re defining this site for the first time, you can also follow steps 3–9 on page 
459 now. 

 3. In the Category list, choose Site Map Layout.

You see the dialog box shown in Figure 14-11.

 4. Click the folder icon next to the Home Page field. Navigate to the home page file 
in the site’s root folder.

Click Select (Windows) or Open (Mac) to set this page as the home page. 

Remember that your home page must be in the root folder. Technically, you can 
choose a file that’s buried several folders deep in your site folder, but don’t do 
it—unless, of course, you really want to tell people to visit your company’s home 
page at www.mycompany.com/about_us/about_me/my_dog/ralphie.html. By speci-
fying a home page in the outer level of your root folder, you can assure that the 
home page will be at www.mycompany.com.

 5. Set any other Site Map preferences you wish.

Figure 14-11:
Here, you define 
the site’s home 
page and set 
preferences for 
Dreamweaver’s 
Site Map view. If 
your home page 
file is named 
anything other 
than index.html 
or index.htm, 
you must specify 
it in the Home 
Page field.
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The Number of Columns field determines how many links can be displayed in a 
single row of the Site Map. For instance, if you set the number of columns to five, 
but the home page has ten links on it, the Site Map only has enough columns for the 
first five links; the remaining five icons get bumped down to a second row directly 
below the first. Displaying more than one row of links from the home page can be 
confusing, so it’s best to use a number of columns that’s at least equal to the number 
of links on the home page. Dreamweaver’s default value of 200 is just fine.

The Column Width represents the width, in pixels, of each column. As you can 
see in the box on page 474, file names and page titles may not fully appear if the 
column width is too small. Again, stick with Dreamweaver’s default value of 125.

Note: The column width and number settings have no effect except when the Files panel is in expanded 
view (Figure 14-7).

Using the Icon Labels buttons, choose whether you want the Site Map to display 
the file name (index.html) or page title (“Welcome to Cosmopolitan Farmer”) 
next to each page’s icon. Shift+Ctrl+T (Shift-c-T) toggles between the two views 
when viewing the Site Map.

Once you’ve got your Site Map on display, you can hide certain files for the sake 
of clutter reduction by marking them as hidden. To make sure they stay hidden, 
leave Display files marked as hidden turned off. You can always make the hidden 
files reappear using the steps described on page 475.

The Display dependent files option will make GIF, JPEG, CSS, Flash, and all other 
non-HTML files show up in the Site Map. Since this can make the site map a con-
fusing jumble of files, it’s best to leave this option turned off.

 6. Click OK.

You return to the Files panel. 

Viewing and Customizing Site Map View
Once you’ve set up Site Map view as described above, you can see it by choosing Map 
View from the Files panel’s unlabeled View menu (identified in Figure 14-6). Because 
the Files panel is narrow, click the Expand/Collapse View button (also shown in Figure 
14-6) to maximize the map area.

When you first view the Site Map, only the first two levels—the home page and all of 
the pages linked from it—appear. A + symbol next to a page indicates that there are 
additional links on that page; clicking the + expands the list of links on that page. If 
those pages in turn have links, additional + symbols appear. You can continue to fol-
low the links by expanding each page, but viewing too many levels at once can bring 
a confusing complication; see the box on page 474 for advice.

As in the Site file list, you can open a page by double-clicking its icon in the Site Map. 
In fact, if the Files panel is expanded (so that both the Site Map and Local Site file 
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listings appear), selecting a page in the Site Map highlights the corresponding page 
in the File list, and vice versa.

Identifying pages in the Site Map
The Site Map view starts out displaying the file name of each Web page, which can 
be less than informative. If you’ve structured your site (as recommended on page 
454) so that the main page for each section of the site is stored in a different folder 
and is named index.html, the Site Map will be an unhelpful sea of index.html labels 
(see Figure 14-10). 

A better approach: use each page’s title as the icon label. You can do this either when 
you first set up the site, as described on page 459, or choose View→Show Page Titles 
from the Files panel’s contextual menu (see Figure 14-13). Repeat the same command 
to see the file names again. The keyboard shortcut is a fast way to toggle between the 
two views: Shift+ Ctrl+T (Shift-c-T). 

Note: In Windows, if the Files panel is expanded, you’ll see a menu across the top of the panel, as pictured 
in Figure 14-12. This menu offers the same options as the contextual menu visible in the collapsed panel, 
shown in Figure 14-10.

Viewing just part of a Web site
When viewing large Web sites, you might find the Site Map awkward. Perhaps you’re 
working on just a single section, and don’t want to be bothered with the extraneous 
details of the rest of the site. No problem: you can isolate a particular page when view-

Don’t Get Lost in the Site Map
The Site Map clearly displays links between pages, but if 
you’re not careful, you may end up chasing your tail. Very 
often, Web pages link back and 
forth to each other. For example, 
the home page may link to a page 
in the site that, in turn, links back 
to the home page. 

In this example illustrated here, 
the horoscopes main page 
(“Horoscopes”) has a link to 
the home page (“The National 
Exasperater”), which links to the 
horoscopes page, which links back 
to the home page, which links to the horoscopes page…and 
so on. All four of the pages indicated by arrows are, in fact, 

the same page!

As shown here, the Site Map 
shows the horoscope page as a 
link from the home page. When 
you then click the + to expand 
the advertising page, you see a 
duplicate icon for the home page 
(whose original icon appears at 
the top of the Site Map). When 
you click the + sign next to the 
home page icon under the horo-
scopes page, you don’t get a new 
level of site links, even though the 

Site Map displays it that way. What you’ve done is “re-ex-
pand” the home page to display more duplicate icons.

GEM IN THE ROUGH
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ing the Site Map. Click a page in the Site Map and choose View→View as Root from 
the Files panel’s contextual menu (Figure 14-13). Alternatively, you can right-click 
(Control-Click) the page and select View as Root from the menu that appears. The 
page you selected appears as the top-level page in the Site Map (see Figure 14-12).

Hiding extraneous links
Like some people you may know, the Site Map loves detail; it includes all links from 
your pages, including external links and email links. At times, this may be a bit more 
information than you need. Suppose you provide 200 email addresses on a single 
page; you probably don’t need to see all of those listed in the Site Map. 

Fortunately, Dreamweaver lets you hide any links you wish. All you have to do is select 
the files you want to hide (Shift-click them, or drag across a group of them) and then 
choose View→Show/Hide Link from the Files panel’s contextual menu, or right-click 
(Control-click) the selected files and choose Show/Hide link from the menu that ap-
pears; Dreamweaver makes them disappear.

To show hidden files again, choose View→Show Files Marked as Hidden from the 
Files panel’s contextual menu. Dreamweaver makes all hidden files appear with their 
names italicized, indicating that you’ve marked them as hidden. You can turn off a 

Figure 14-12:
This Site Map is zoomed in on a single page 
(Leo), which appears at the top level of the Site 
Map where the home page normally would be. 
The path from the home page to this file appears 
above the map in the Site Navigation bar. The 
home page is titled “The National Exasperater.” 
A link from the home page leads to a page titled 
“Horoscopes,” which in turn links to the “Leo” 
horoscope page. To once again view the home 
page as the top level of the Site Map, click its 
name in the Site Navigation bar. 

Printing Your Site Map
After perfecting your Site Map, you may want to make a 
hard copy of it. While Dreamweaver won’t print the Site 
Map (why, Macromedia, why?), you can save it as a graphic 
and then print it. 

Here’s the ritual: In Site Map view, choose File→Save Site 
Map from the Files panel’s contextual menu (for Windows, 
if the panel is expanded, you can select Save Site Map from 

the File menu at the top of the window). Name the graphic 
and save it onto your computer. (Windows users can also 
choose a file format for the graphic—PNG or BMP. On the 
Mac, Dreamweaver saves the map as a PICT file.)

To print the resulting graphics file, double-click it to open it 
in, say, Image Viewer (Windows) or Preview (Macintosh). 
You can print it from there. 

WORKAROUND WORKSHOP
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file’s “hidden” status by selecting it and choosing View→Show/Hide Link, or right-
clicking (Control-clicking) the file and choosing Show/Hide link. 

Renaming Pages in the Site Map
You can rename files in Site Map view, which works similarly to renaming them in the 
File List view. However, only the Site Map lets you easily change the titles of your site’s 
Web pages. In fact, this is one of the best features of the Site Map. While displaying 
the page titles, you can quickly scan your site for missing or incorrect page titles and 
fix them in just a few steps. 

You rename a file in the Site Map just as you do in the Files panel; the steps appear 
on page 469. In this case, just be sure you’re looking at the right kind of data—either 
page titles or file names—before you begin. Press Shift+ Ctrl+T (Shift-c-T) to switch 
back and forth when viewing the Site Map. 

When you’re finished, Dreamweaver rewrites the title in the HTML of the page. The 
new title also appears next to the page icon. Or, if you’ve changed the name of the file, 
Dreamweaver’s Update Files dialog box appears, letting you fix any links that point 
to the newly named file.

Figure 14-13:
Most of the commands in the Context menu 
are duplicated in the panel itself, but three 
options appear only on this menu. Recreate 
Site List comes in handy if you’ve added or 
deleted files outside Dreamweaver. It rebuilds 
the site cache and updates the list of assets. 
Copy to Site copies the selected asset to 
another site. Locate in Site opens the Files 
panel and highlights the file of the asset you 
selected in the Assets panel. You can also 
open a contextual menu by right-clicking 
(Control-clicking) any asset in the list.

Images
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Flash

Shockwave
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Templates
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Site Assets
Web pages integrate lots of different elements: GIFs, JPEGs, links, colors, and Flash 
and Shockwave movies, to name just a few. In a large site with lots of files, it can be a 
challenge to locate a particular image or remember an exact color. 

To simplify the process, Dreamweaver provides the Assets panel. For want of a better 
generic term, Macromedia defines the term asset to mean any element you use on a 
Web page, such as a GIF file, a link, or even an individual color. 

Viewing the Assets Panel
Dreamweaver lists your site’s assets on the nine category “pages” of the Assets panel 
(Figure 14-13). To open the panel, choose Window→Assets, or press F11.

You select an asset in the list by clicking its name; a miniature preview appears above 
the Assets list. To preview a movie, click the green arrow that appears in the preview 
window. 

The assets panel highlights nine different categories of site elements. To view the assets 
in a particular category, click its icon at the left of the Assets panel.

 •  The Images category lists all of the GIF, JPEG, and PNG files in your site. 

 •  The Colors category shows all of the colors specified in the Web pages and 
embedded style sheets of your site. These include link colors, background colors, 
and text colors. Unfortunately, it doesn’t include colors you’ve specified in linked 
style sheets. (For more detail on linked style sheets, see page 149.)

 •  The URLs category lists all external links—not just standard http:// links, but 
also email links, FTP addresses, and JavaScript links. (For an example of a JavaScript 
link, see the box on page 379.) 

 •    The multimedia categories—Flash, Shockwave, and Movies—are 
roughly equivalent. They each display movie files with their corresponding 
extensions: .swf (Flash), .dcr (Shockwave), and .mov or .mpg (QuickTime and 
MPEG).

 •  The Scripts category lists JavaScript or VBScript files. This category only in-
cludes external script files that Web pages link to. Scripts that are embedded into 
a Web page—like those created using Dreamweaver Behaviors—are not listed.

 •   The last two categories—Templates and Library—are advanced assets that 
streamline Web site production. They’re discussed in Chapters 17 and 18.

You can switch between two different views for each asset category—Site and Favor-
ites—by clicking the radio buttons near the top of the Assets panel. The Site option lists 
all the assets that appear in the Site for the chosen category. Favorites lets you create 
a select list of your most important and frequently used assets (see page 480). 

Site Assets
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Note: Dreamweaver’s cloaking feature lets you hide files from many sitewide tasks, including the Assets 
panel. So, if you have a folder with thousands of image files that you’d rather not display on the Assets panel, 
you can hide that folder and its files. See page 528 for more on this feature.

If, as you are working on a site, you add additional assets—for example, you create 
a new GIF image in Fireworks and import it to the site—you’ll need to update the 
Assets panel. Click the Refresh List button ( ) to update the list of assets.

Inserting Assets
The Assets panel’s prime mission is to make using assets easier. From the Assets list, 
you can add graphics, colors, and links to your pages with a click of the mouse. Most 
of the categories on the panel refer to external files that you can include on a Web 
page: images, Flash, Shockwave, movies, and scripts. 

The easiest way to insert an asset file is to drag it from the Assets panel into the docu-
ment window. You can drag the asset anywhere on the page you’d normally insert 
an object—in a table cell, at the beginning or end of a page, or within a paragraph. 
Script assets can go in the head of a Web page (see Figure 14-14).

(If you’re billing by the hour, you may prefer the long way: Click in the document 
window to plant the insertion point, click the asset’s name, and then click Insert at 
the bottom of the Assets panel.)

Adding color and link assets
Color and link assets work a bit differently than other asset files. Instead of standing 
on their own, they add color or a link to images or text you’ve selected in the docu-
ment window. (You can add colors to any text selection, or add links to images and 
text.) In this way, you can quickly add a frequently used link—the URL to download 
the Flash player or Adobe Acrobat reader, for example.

The Return of Root-Relative Paths
Chapter 4 explains the different types of link paths—absolute, 
document-relative, and root-relative—that Dreamweaver 
understands (see page 93). While it’s best to use document-
relative paths for linking to pages within your own site, or for 
adding images and other media to a page, you may notice 
that Dreamweaver frequently displays root-relative paths in 
its site management tools. 

For instance, the list in the Assets panel includes the full root-
relative path of each asset—/images_home/banner.gif, for 
example. The initial “/” indicates the root folder of the site, 

and the information that follows indicates the rest of the path 
to that asset. In this example, the graphic asset banner.gif is 
in a folder called images_home, which is itself in the site’s 
root folder. Dreamweaver needs to look no further than the 
root folder to find the asset in question.

Root-relative paths indicate a precise location within a site 
and let Dreamweaver know where to find a file. This doesn’t 
mean, however, that you should use root-relative paths 
in your Web sites. Use document-relative paths—and let 
Dreamweaver do its own thing. 

POWER USERS’ CLINIC
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To do so, start by highlighting the text (to change its color or turn it into a link) 
or image (to turn it into a link). In the Assets panel, click the appropriate category  
button—Colors or Links. Click the color or link you want, and then click Apply. 
Alternatively, you can drag the color or link asset from the panel to the selection.

Note: Applying color to text using the Assets panel either creates a new CSS style or wraps the selected text 
in a <font> tag. The actual result depends on the Preferences setting described on page 80. 

Figure 14-14:
While you’ll insert most assets into the 
body of a Web page, you can (and 
usually should) place script files in 
the head of the page. To do this, first 
choose View→Show Head Content. 
Then drag the script from the Assets 
panel into the head pane, as shown 
here. (Adding a script asset does not 
copy the JavaScript or VBScript code 
into the Web page. Instead, just as with 
external style sheets, Dreamweaver 
links to the script file so that when a 
Web browser loads the page, it looks 
for and then loads the file from the 
Web site.) 

Better Use of Color Assets
Although color assets are only meant for coloring text, you 
can use them any time Dreamweaver’s eyedropper tool 
appears, such as when you’re about 
to apply color to tables, table cells, 
links, pages, and other elements. In 
other words, anytime you need a 
frequently used color, you can hop 
right to the Assets panel rather than 
pecking around on the color palette 
or trying to find another occurrence 
of the color on your screen.

Whenever you click a color box—in 
the Page Properties window, Prop-

erty inspector, or Style Definition window, for example—a 
color palette appears and the cursor changes to an eyedrop-

per. You could, of course, use this 
eyedropper to pick a color from the 
palette or to sample a color from 
the screen. But if you’ve already 
used the color in your site—or 
saved it in the Favorites list (see 
page 480)—just grab it from the 
Assets panel. To do so, move the 
eyedropper to the colored swatch 
in the Assets list and click.

GEM IN THE ROUGH
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Favorite Assets
On a large site, you may have thousands of image files, movie files, colors, and external 
links. Because scrolling through long lists of assets can be a chore, Dreamweaver lets 
you create a compact list of your favorite, frequently used assets. 

For example, you might come up with five main colors that define your site’s color 
scheme, which you’ll use much more often than the other miscellaneous colors on 
the Assets list. Add them to your list of favorite colors. Likewise, adding graphics 
files you use over and over—logos, for example—to a list of favorites makes it easy 
to locate and insert those files into your pages. (Don’t forget that you can also use 
Dreamweaver’s Library and Template features for this function. They’re similar, but 
more powerful tools for keeping frequently used items at the ready. Turn to Chapter 
17 for the details.)

Identifying your Favorites
If the color, graphic, or other element to be added to your Favorites list already ap-
pears on your Assets panel, highlight it in the list and then click the Add to Favorites 
button ( ). 

Even quicker, you can also add Favorites as you go, snagging them right from your 
Web page in progress. If you’re working on your site’s home page and you insert a 
company logo, for example, that’s a perfect time to make the logo a favorite asset.

Simply right-click (Control-click) the image. From the contextual menu, choose 
Add to Favorites; Dreamweaver instantly adds the graphic to your list of favorites. 
You can do the same with Flash, Shockwave, and QuickTime files, as well with links. 
(Unfortunately, this shortcut doesn’t work for colors and script files.)

When it comes to colors and links, there’s another way to turn them into Favorites. In 
the Assets panel, select the Color or URLs category, click the Favorites radio button, 
and then click the New Asset button ( ). Then:

 • If you’re adding a favorite color, the Dreamweaver color box appears. Select a color 
using the eyedropper (see page 35). 

 • If you’re adding a favorite link, the Add URL window opens. Type an absolute URL 
in the first field, either a Web address starting with http:// or an email link—mailto:
subscriptions@nationalexasperater.com. Next, type a name for the link in the Nick-
name field—Acrobat Download or Subscription Email, for instance—and then 
click OK.

Your new color or link appears in the Favorites list.

Using your Favorites
You insert assets from the Favorites list into your Web pages just as you would any 
assets; see page 478.
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Removing Favorites
Removing assets from the Favorites list is just as straightforward as adding them: just 
select one in the Favorites list of your Assets panel and then press Delete. The Remove 
from Favorites button ( ) on the Assets panel does the same thing. Yet another ap-
proach is to use the contextual menu (see Figure 14-13). 

Don’t worry; removing an asset from the Favorites list doesn’t delete that asset from 
the Assets panel—only from the Favorites list. You can still find it listed if you click 
the Site radio button.

Organizing Favorite assets
On a large site with lots of important assets, even a Favorites list can get unwieldy. 
That’s why you can set up folders within the Assets panel to organize your assets. For 
example, if you use lots of ads on a site, create a folder in the Image assets Favorites 
called Ads or, for even greater precision, create multiple folders for different types of 
ads: Banner Ads, Half Banner Ads, and so on. 

You can then drag assets into the appropriate folders, and you can expand or contract 
the folder to show or hide the assets inside (see Figure 14-15). These folders simply 
help you organize your Assets panel; they don’t actually appear anywhere within the 
structure of your site. Moving a Favorite asset into a folder in the Assets panel doesn’t 
change the location of files within your site.

Figure 14-15:
In addition to using folders to organize your favorites, you can also 
give a Favorite asset an easily identifiable nickname. Instead of 
listing a favorite image using its file name—148593.gif—use an easily 
understood name like New Product. Naming favorite colors can 
be particularly helpful—a nickname like Page Background is more 
descriptive than #FF6633. To name a Favorite asset, click to select it, 
pause a moment, and click again to edit its name. (These nicknames 
only apply in the Assets panel; they don’t rename or retitle your files.)
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To create a Favorites folder, click the appropriate category button at the left edge 
of the Assets panel (any except the bottom two, since you can’t create folders for  
Templates and Library items). Click Favorites at the top of the Assets panel (you can’t 
create folders in Site view). Finally, click the folder button ( ) at the bottom of the 
Assets panel. When the new folder appears with its naming rectangle highlighted, 
type a new name for the folder and then press Enter. (Don’t use the same name for 
more than one folder.)

To put an asset into a folder, just drag it there from the list. And if you’re really obses-
sive, you can even create subfolders by dragging one folder onto another.
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