
SECURITY & SEARCH

Distributing your finished pdf document to others may feel like sending your 5-year old daughter

off to kindergarten for the first time. You want your child to meet other children, but you also

need to protect her from talking to strangers, going to the wrong school, losing her lunch money

to bullies, or even from telling other children your personal family secrets. Fortunately, there are

several different ways you can protect pdf documents by setting the built-in security options.

Restricting Viewing and 
Editing with Security 

8.1

Document security is an increasingly important

factor in  work flow, particularly for docu-

ments that will be shared through e-mail, -

, intranets, or the Internet. There are

many different levels of security

needed for  documents. For

example, companies may send

advance notice of new docu-

ments to their retail sales part-

ners. The company doesn’t want

others to be able to open these

documents. Another company

may send a price sheet that they

want to protect from someone

altering the prices. An author may want to post

a chapter from her book, but doesn’t want any-

one to be able to extract the text or graphics

to use in their own documents. A publishing

house may distribute books as  files, but

not allow the books to be printed.

Acrobat lets you set a password at two dif-

ferent levels. The User password is required

to allow people to open the document. Once

the document is open, a Master password is

required to change the security settings. In

Acrobat version 5, the type of security encryp-

tion has been increased. This makes it harder

for someone to break into a document. It also

allows users to share documents between peo-

ple or locations with less fear of unauthorized

viewing, printing, or editing. (Remember, no

security solution is foolproof, but we’ll cover

that later.) Acrobat security settings can be

specified when you first create a  file or at

any time after the file has been created. Once

you set the security restrictions, the tools and

menu items related to the restricted features are

dimmed in the tool bar and the main menu.

This means that these tools are no longer acces-

sible in the document.

PROTECTING WITH PASSWORDS

A  file can be protected with two passwords.

A lower-level User password is set as the pass-

word required to open the document. A higher-

level Master password is set as the password

required to change any of the security options.

You cannot choose the same password as both

the User and the Master passwords. If a file has

been protected with both a User and a Master

password, you can use either one to open the

file. If you open a file with a User password,

you’ll still need to enter the Master password

in order to change the security options. Any

restrictions on modifying and printing the

document remain in effect. If you open a file

with the Master password, you can also change

the security options and all modifying and

MORE SECURITYi
There are lots of security
add-on options for Acrobat
pdf files. As of this writing,
we know of at least 11 com-
panies that provide security
features that can be inte-
grated into pdf documents.
These companies include
Entrust Technologies,
FileOpen Systems, and
Appligent. 
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DOCUMENT SECURITY OVERVIEW

Document Security
options control
which features are
active for a particular
document, in either
Acrobat or Acrobat
Reader.

The Document Secu-
rity dialog box shows
which options in the
document are
allowed or not
allowed. 

Document Security
causes certain tool
bar icons and menu
options to become
unavailable.

Don’t think you can
get around the secu-
rity options by sav-
ing a copy of the file.
The security options
stay in place for the
new file.

Even commands
that appear to be
allowed, such as
saving text, will be
denied.

When a user pass-
word had been set,
the password dialog
box appears as the
file is opened. The
user must enter the
correct password to
open the file. 
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SECURITY & SEARCH

printing restrictions can be turned off. (That’s

why we call the Master password the high-level

security option.)

The most common method of securing a

document is to set only the Master password.

This lets anyone open the document without

any restrictions, but only the master can change

the security settings. If a User password has

been set, but there is no Master password, then

anybody who opens the document can change

the security settings. Obviously, this type of

security would be pointless. Yet we receive

many  documents that have precisely this

sort of brain-dead security setting. We also get

a lot of documents that have very specific secu-

rity settings, but no Master pass-

word at all. In these cases, anyone

can march right in and change

the security options.

Please be cautious and

fastidious about documenting,

tracking, and storing the pass-

words to your documents. If a

password is lost or forgotten,

there is no easy way to recover it.

There are third-party solutions

out there that will attempt to

recover a password from a doc-

ument, but this could take days

or weeks, if recovery is successful

at all. Legitimate password-recovery companies

also require verification that you or your organ-

ization are the legal owners of the secured files

and that the password recovery solutions will

not be used for illegal activity. In general, the

longer the password—the more difficult and

longer the recovery.

At the basic software level, Acrobat does

provide a measure of built-in protection. If you

need added security, there are companies such

as FileOpen and Appligent that offer plug-ins,

add-ons, and server-based solutions that

increase  security. Just as in real life, tighter

 security comes with a price tag that might

include usability issues. Digital rights manage-

ment solutions for eBooks are an example of

security measures that often result in an unus-

able document. Many eBook users complain

that that when they upgrade system software,

the eBook file is no longer recognized or that

they can’t transfer it to a new computer or .

We’re all for protecting intellectual property,

but the cost in time and frustration may sim-

ply not worth the added security.

With that said, let’s get on with the basics.

Acrobat has two basic built-in security options;

Standard Security and Self-Sign Security. Both

are accessed from File>Document Security, and

both choices contain numerous options for

restrictions and levels of document encryption.

PASSWORD CHOICESi
The longer a password, the
harder it is to break into a
document. Nonsense combi-
nations of letters such as
“zxcv” are harder to deci-
pher than real words. Also,
mixing cases, numbers, and
symbols such as “Zx$2” is
even more secure. Whatever
password you choose, don’t
pick one like the password
we found in a pdf file from
a company we’ll call “Acme
Software.” Someone set the
Master password for a docu-
ment we got from them as
“Acme.”

Add security to a docu-
ment using the Docu-
ment Security options.
Choose File>Document
Security to open the dia-

Set the user password to
enable the basic pass-
word security feature. All
users must enter a given
password to access the
file. Passwords are case
sensitive.

The 40-bit encryption
offers backwards com-
patibility with Acrobat
3.x and 4.x. It provides
four options for docu-
ment permissions.

STANDARD SECURITY

log box. Choose Acrobat
Standard Security from
the Security Options
list.The Standard Secu-
rity dialog box opens.
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SETTING STANDARD SECURITY

The Standard Security option is the most com-

mon and easiest type of security to apply. It is

used with documents that will be distributed

to people you do not know.

Step Open the Security Options

Open a  in Acrobat  and choose File>Doc-

ument Security. Choose Acrobat Standard Secu-

rity from the Security Options

list. This will automatically open

the Standard Security dialog box.

Step Enter the Passwords

If you want to restrict certain

Acrobat features, such as editing

and printing, select Master Pass-

word and then type that password

into the Master Password field.

To restrict opening of the docu-

ment to only those who have a

password, select User password

and then type that password in

the User Password field. Passwords are case

sensitive.

Step Set the Encryption Level

Use the Encryption Level list to set the com-

plexity of the encryption of the document.

The -bit encryption is a weaker level of

encryption that is also used with Acrobat 3

and 4 documents. This setting should be used

if you anticipate that the document will be

opened by Acrobat 4 or Acrobat Reader 4. The

-bit encryption is stronger, and works only

with Acrobat  or Acrobat Reader 5. A docu-

ment with -bit encryption settings cannot

be opened by Acrobat version 4 or 3.

Step Control the Permissions

Although the two encryption levels are worded

differently, the results are similar. However, the

-bit encryption does provide a finer control

over the options.

Enable Content Access for the Visually

Impaired allows the document to be read by

screen readers or other such devices. When

this option is turned on, the security of the

document is lowered.

Allow Content Copying and Extraction lets

the user select and copy text and graphics. It

also lets them extract images or save the doc-

ument in a text format. Turn this off if you

don’t want others using your text or images in

their own work.

The Changes Allowed list lets you choose

what type of changes can be made. The options

go from bottom to top in order of increasing

level of restriction.

The Printing list lets you choose three

options for printing. Fully allowed lets the

user print with complete fidelity to the origi-

nal images. Low Resolution limits the printing

to the screen resolution of images and fonts.

Once you have chosen
the encryption level and
whether you need com-
patibility with Acrobat 4,
you can select from a
variety of permissions for
the document.

TOTAL SECURITYi
In case your mother never
warned you, there are nasty,
evil people out there. Just
because you add security to
a document doesn’t mean
that someone (like a 12-year
old kid) won’t try to hack
into your document. There
are constant reports of secu-
rity flaws discovered in Acro-
bat and other electronic
media. If your life’s work
would be lost if someone
breached your document’s
security, then don’t distrib-
ute it as a PDF file.

These are the options for
setting 128-bit permis-
sions. The permissions for
both encryption levels are
similar; but worded differ-
ently. 128-bit encryption is
slightly more flexible.
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RESTRICTING ACCESS WITH DISTILLER

You can also secure documents at the same time

they are created. Start Distiller, and choose

Settings>Security. You will be given the same

-bit encryption dialog box that you see when

setting document security in Acrobat. If you

want to apply -bit security to your docu-

ments, you must first create a custom Job

Options set. Start by choosing which set of Job

Options you want to base your custom settings

on (eBook, Print, Screen, etc.) and then select

Settings>Job Options>Compatibility Acrobat .

If you have based this new set on one of the

“canned” Acrobat job options,

then it will ask you to name and

save this new set in the Job

Options folder. Now, when you

select Settings>Security, you’ll

see the dialog box for -bit

encryption. You can also apply

these security settings to the job

options assigned to Watched

Folders.

REMOVING SECURITY 

There are times when you need

to remove the security from a document. We

remove security settings (especially the User

password) when we’re opening, closing, and

making changes to a document. As long as you

know the Master Password, removing security

is easy. Go to File>Document Security. When

the initial dialog box appears, select No Secu-

rity from the Document Security pull-down

menu. If you did not use the Master Password

to open the document, a dialog box appears

that asks for the Master Password. Acrobat 

will also ask if you are sure that you want to 

remove the security. Choose Yes, and the

security is lifted.

SETTING SECURITY 
FOR BATCH PROCESSING 

If you’d like to apply the same security settings

to a group of  files, you can use Acrobat’s

built-in batch processing capabilities. What-

ever you do, don’t run the pre-made sequence

that ships with Acrobat 5 labeled “Set Security

to No Changes.” While it will indeed set the

security on all the chosen documents to No

Changes, it does not add a Master password

to keep someone from changing the Security

Options (brain-dead security).

Fortunately, it’s not too hard to create your

own batch processing security setting.

Step Create a New Batch Sequence

Choose File>Batch Processing>Edit Batch

Sequences. In the Batch Sequence dialog box,

click the New Sequence button. Enter a name

for the sequence and click .

Step Add Security to the Sequence

In the Batch Edit Sequence dialog box that

You can create your own
batch processing setting
for setting security options.
Choose File>Batch Pro-
cessing>Edit Sequences.

SECURITY & SEARCH

SEARCH & SECURITYi
If you want users to be able
to use the Catalog and
Search functions on docu-
ments that don’t allow con-
tent extraction, they must be
sure to select the Certified
Plug-ins Only option in their
Options preferences. You
may need to include instruc-
tions on how to change the
preferences. Choose Edit>
Preferences>General>
Options. Check the box by
Start Up>Certified Plug-ins
only and restart Acrobat.

Select Security in the
left pane and click the
Add button. Then

select the setting on
the right side and click
the Edit button.

Click the New Sequence
button and name your
new sequence. Then
click ok.

ADDING BATCH SECURITY
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opens, click the Select Commands button and

then choose Security in the Document group

in the left pane. Then click the Add button.

This adds the Security listing to the right side

of the dialog box. You now need to define the

security options.

Step Define the Security Options

Select the Security listing and click the Edit but-

ton. This opens the Document Security dialog

box. Choose Acrobat Standard Security and

click the Change Settings button.

This opens the Standard Secu-

rity dialog box. Define the secu-

rity options you want for your

batch sequence—make sure you

enter a Master password. Click

 as many times as necessary

to close the dialog boxes. The new

sequence appears in the Batch Processing sub-

menu. See the Batch Processing section in the

previous chapter for more on running batch

sequences.

Choose Acrobat Stan-
dard Security from the
Security Options, and
then click the Change
Settings button.

Set the Standard
Security options for
the batch sequence.

ENCRYPTIONi
Acrobat uses the rc4
method of security from rsa
Corporation to secure pdf
files. When you use Acrobat
Self-Sign Security, your doc-
ument is automatically
encrypted at -bit rc4.
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